QNAP TS-412 dejan de funcionar recursos de red con Windows 10

Supongo que a estas alturas todos ya habremos oído hablar del ransomware WannaCry que aprovechaba la vulnerabilidad del protocolo SMB v1.0 la cual Microsoft publicó un parche ya hace meses.

Puede que de igual forma que me sucedió a mi, a muchos otros sistemas nuevos o algo más antiguos hayan dejado de funcionar algunos servicios de red, como por ejemplo los recursos compartidos.

Sin ir más lejos mi unidad NAS QNAP TS-412 que utilizo a nivel personal dejé de acceder a mis recursos de red que tenía. En un principio pensé que podía haber sido la propia NAS que habría fallado algo, pero al acceder desde una tablet con Android comprobé que todo seguía funcionando correctamente dentro de la NAS.

Comprobé servicios en mi Windows 10, así como que no fuese el firewall o el antivirus. Todo parecía correcto. Accediendo a mi mismo accedía correctamente.

 

Revisando foros del fabricante de la NAS vi que mi modelo y encima del firmware 4.1 soportaba SMB v2 y SMB v3, así que algo tenía que estar mal en algún sitio.

Llegué hasta este post, donde explicaban como reinstalar el protocolo SMB que deseemos. Pero accediendo a mi NAS, esos comandos no existían. Así que encontré otro con los que forzar la versión de SMB que deseemos utilizar.

Los pasos a seguir son:

  • Iniciamos nuestro Putty para conectarnos a nuestra NAS
  • Nos dirigimos a la ruta /etc/init.d/ y listamos todos los archivos smb*

  • Nos mostrará dos archivos. Si ejecutamos smb2_protocol.sh nos mostará un pequeño menú con varias opciones y la versión de SMB que estamos ejecutando.

  • En mi caso quiero activar SMB v3, así que deberjé ejecutar el comando: smb2_protocol.sh enable 3

  • Esto reconfigurará la versión a utilizar y reiniciará los servicios.

Si todo ha ido correctamente ya podremos acceder a nuestras unidades compartidas.

 

Como última recomendación, comentar que la gente de QNAP en el caso de utilizar SMB v3.0 recomienda subir la MTU a 9000.

Para cambiarlo de forma fácil, accederemos vía web y nos dirigimos a los siguientes apartados.

  • Panel de control > Red > Editanos nuestras conexiones > Jumbo Frame (MTU): 9000

  • Aplicamos y reiniciará los servicios nuevamente.

 

How useful was this post?

Click on a star to rate it!

Average rating / 5. Vote count: